makedeb


iptables-fullconenat 20220213064119.108a36c-2


FULLCONENAT extension for iptables.

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for iptables-fullconenat.

# Maintainer: Menci <huanghaorui301@gmail.com>
# Contributor: Edward Pacman <edward@edward-p.xyz>

pkgname=iptables-fullconenat
pkgver=20220213064119.108a36c
pkgrel=2
pkgdesc='FULLCONENAT extension for iptables.'
arch=(any)
license=(GPL2)
url='https://github.com/llccd/netfilter-full-cone-nat'
makedepends=(libxtables-dev pkg-config)
source=("$pkgname::git+$url.git")
sha1sums=('SKIP')

pkgver() {
  cd "$srcdir/$pkgname"
  ( set -o pipefail
    printf "%s.%s" "$(git log -1 --format="%at" | xargs -I{} date -d @{} +%Y%m%d%H%M%S)" "$(git rev-parse --short HEAD)"
  )
}

build() {
  make -C "$srcdir/$pkgname" libipt_FULLCONENAT.so libip6t_FULLCONENAT.so
}

package() {
  cd "$srcdir/$pkgname"

  XTABLES_LIBDIR="$pkgdir$(pkg-config xtables --variable=xtlibdir)/"
  mkdir -p "$XTABLES_LIBDIR"
  install -Dm 0644 libipt_FULLCONENAT.so libip6t_FULLCONENAT.so "$XTABLES_LIBDIR"
}

# vim:set sw=2 et: