makedeb


i3-gaps-git 18447a9b2022.03.28-2


A fork of i3wm tiling window manager (development branch) with more features, including gaps

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for i3-gaps-git.

# Maintainer: only_vip <onlyme_vip@protonmail.com>
pkgname=i3-gaps-git
_pkgname=i3
pkgver=18447a9b2022.03.28
pkgrel=2
pkgdesc='A fork of i3wm tiling window manager (development branch) with more features, including gaps'
arch=('i686' 'amd64')
url='https://github.com/Airblader/i3/tree/gaps-next'
license=('BSD')
provides=('i3-wm')
conflicts=('i3-wm')
depends=('meson' 'dh-autoreconf' 'xcb' 'libxcb-xrm0' 'libxcb-shape0')
makedepends=('git' 'bison' 'flex' 'asciidoc' 'xmlto' 'meson' 'libxcb-keysyms1-dev' 'libpango1.0-dev' 'libxcb-util0-dev' 'libxcb1-dev' 'libxcb-icccm4-dev' 'libyajl-dev' 'libev-dev' 'libxcb-xkb-dev' 'libxcb-cursor-dev' 'libxkbcommon-dev' 'libxcb-xinerama0-dev' 'libxkbcommon-x11-dev' 'libstartup-notification0-dev' 'libxcb-randr0-dev' 'libxcb-xrm-dev'  'libxcb-shape0-dev')
optdepends=('rxvt-unicode: The terminal emulator used in the default config.'
            'dmenu: As menu.'
            'i3lock: For locking your screen.'
            'i3lock-fancy: For locking your screen.'
            'i3status: To display system information with a bar.')
source=("${_pkgname}::git+https://github.com/Airblader/i3#branch=gaps-next")
sha512sums=('SKIP')

pkgver() {
    cd "${srcdir}/${_pkgname}"
    _always=$(git describe --always | sed -e 's:-:.:g' -e 's:vNext::') # always is mobile, and switches between numbers and letters, can't use it for versioning
    _commits=$(git rev-list --count HEAD | sed 's:-:.:g') # total commits is the most sane way of getting incremental pkgver
    _date=$(git log -1 --date=short --pretty=format:%cd)
    printf "%s%s%s\n" "${_commits}" "${_always}" "${_date}" | sed -e 's:-:.:g'  -e 's:_:.:g'
}

build() {
  cd "i3"
   meson \
    -Ddocs=true \
    -Dmans=true \
    -Dprefix=/usr \
  ../build
  meson compile -C ../build
}

package() {
  cd "i3"
  DESTDIR="${pkgdir}" meson install -C ../build
  install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 LICENSE
}