makedeb
A third-party, open-source ProtonMail CardDAV, IMAP and SMTP bridge
Viewing /PKGBUILD
.
Click here to go back to the Git tree for hydroxide.
# Maintainer: hiddeninthesand <hiddeninthesand at pm dot me>
pkgname="hydroxide"
_gitname="hydroxide"
pkgver='0.2.27'
pkgrel='1'
pkgdesc="A third-party, open-source ProtonMail CardDAV, IMAP and SMTP bridge"
arch=("any")
url="https://github.com/emersion/hydroxide"
license=('MIT')
makedepends=('golang-go')
sha256sums=('SKIP')
source=("git+https://github.com/emersion/hydroxide.git#tag=v${pkgver}")
conflicts=("${_gitname}-git" "${_gitname}-bin")
build() {
cd ${_gitname}
GO111MODULE=on go build ./cmd/hydroxide
}
package() {
cd ${_gitname}
install -Dm755 "${_gitname}" "${pkgdir}/usr/bin/hydroxide"
}