makedeb


hydroxide-git 1.1.4c32801-1


A third-party, open-source ProtonMail CardDAV, IMAP and SMTP bridge

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for hydroxide-git.

# Maintainer: hiddeninthesand <hiddeninthesand at pm dot me>

pkgname="hydroxide-git"
_gitname="hydroxide"
pkgver=1.1.4c32801
pkgrel=1
pkgdesc="A third-party, open-source ProtonMail CardDAV, IMAP and SMTP bridge"
arch=("any")
url="https://github.com/emersion/hydroxide"
license=('MIT')
makedepends=('golang-go')
sha256sums=('SKIP')
source=("git+https://github.com/emersion/hydroxide.git")
conflicts=("${_gitname}" "${_gitname}-bin")

pkgver() {
  cd "${_gitname}"

  printf "1.%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" | sed 's|^v||'
}

build() {
	cd ${_gitname}
	GO111MODULE=on go build ./cmd/hydroxide
}

package() {
    cd ${_gitname}
	install -Dm755 "${_gitname}" "${pkgdir}/usr/bin/hydroxide"
}