makedeb
Hurl, run and test HTTP requests with plain text.
Viewing /PKGBUILD
.
Click here to go back to the Git tree for hurl-bin.
# Maintainer: Your Name <foobar@example.com>
# vim: set sw=4 expandtab:
repology_pkgname=hurl-http-requester
pkgname=hurl-bin
pkgver=6.0.0
pkgrel=4
pkgdesc='Hurl, run and test HTTP requests with plain text.'
arch=('amd64')
provides=(hurl)
conflicts=(hurl)
options=()
license=('Apache-2.0 license')
url='https://hurl.dev/'
extensions=()
source=("https://github.com/Orange-OpenSource/hurl/releases/download/$pkgver/hurl-$pkgver-x86_64-unknown-linux-gnu.tar.gz")
sha256sums=('20bed7a6b76060f6577d1f5dd1aa4c6b9e4462d9700b53c86aa641fe38ea7db1')
package() {
cd "$srcdir/hurl-$pkgver-x86_64-unknown-linux-gnu/"
install -Dm755 "bin/hurl" "$pkgdir/usr/bin/hurl"
install -Dm755 "bin/hurlfmt" "$pkgdir/usr/bin/hurlfmt"
install -Dm655 "man/man1/hurl.1.gz" "$pkgdir/usr/share/man/man1/hurl.1.gz"
install -Dm644 "man/man1/hurlfmt.1.gz" "$pkgdir/usr/share/man/man1/hurlfmt.1.gz"
}