makedeb


hurl-bin 5.0.1-4


Hurl, run and test HTTP requests with plain text.

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for hurl-bin.

# Maintainer: Your Name <foobar@example.com>
# vim: set sw=4 expandtab:
repology_pkgname=hurl-http-requester
pkgname=hurl-bin
pkgver=5.0.1
pkgrel=4
pkgdesc='Hurl, run and test HTTP requests with plain text.'
arch=('amd64')
provides=(hurl)
conflicts=(hurl)
options=()
license=('Apache-2.0 license')
url='https://hurl.dev/'
extensions=()

source=("https://github.com/Orange-OpenSource/hurl/releases/download/$pkgver/hurl-$pkgver-x86_64-unknown-linux-gnu.tar.gz")
sha256sums=('b1f1bb24f889842f74e6b1a79df15aebd179b9e585639b8a2a2d55b22c295cc3')

package() {
    cd "$srcdir/hurl-$pkgver-x86_64-unknown-linux-gnu/"
    install -Dm755 "bin/hurl" "$pkgdir/usr/bin/hurl"
    install -Dm755 "bin/hurlfmt" "$pkgdir/usr/bin/hurlfmt"
    install -Dm655 "man/man1/hurl.1.gz" "$pkgdir/usr/share/man/man1/hurl.1.gz"
    install -Dm644 "man/man1/hurlfmt.1.gz" "$pkgdir/usr/share/man/man1/hurlfmt.1.gz"
}