makedeb


gendesk 1.0.9-4


Utility for generating desktop files

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for gendesk.

# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>
# Contributor: Alexander F. Rødseth (ARCH) <xyproto@archlinux.org>
# Contributor: zocker_160 <zocker1600 at posteo dot net>

pkgname=gendesk
pkgver=1.0.9
pkgrel=4
pkgdesc='Utility for generating desktop files'
arch=('amd64')
url='https://gendesk.roboticoverlords.org/'
license=('MIT')
#possible alternative: gccgo-go
makedepends=('golang-go')
source=("https://roboticoverlords.org/$pkgname/$pkgname-$pkgver.tar.xz")
b2sums=('07ba72b713bd240e9035ced7555e02bd544ba402a4cf1e8417804ea3d53d7c43cbd47da507b15de0446d07e0b9d84a9bf3c3327b6d508e7f6ced279b2cd6b961')
options=('!lto')

build() {
  cd $pkgname-$pkgver
  go build -v -mod=vendor -trimpath -buildmode=pie -ldflags="-s -w -extldflags $LDFLAGS"
}

package() {
  cd $pkgname-$pkgver
  install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
  install -Dm644 $pkgname.1.gz "$pkgdir/usr/share/man/man1/$pkgname.1.gz"
  install -Dm644 default.png "$pkgdir/usr/share/pixmaps/default.png"
  install -Dm644 LICENSE "$pkgdir/usr/share/doc/$pkgname/LICENSE"
  install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/readme"
  install -Dm644 CHANGELOG.md "$pkgdir/usr/share/doc/$pkgname/changelog"
  gzip "$pkgdir/usr/share/doc/$pkgname/changelog"
}