makedeb


falkon-profiles 2-4


Manage multiple Falkon profiles

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for falkon-profiles.

# Maintainer: bunnylo1 <bunnylo12@yahoo.com>

pkgname='falkon-profiles'
pkgver=2
pkgrel=4
pkgdesc="Manage multiple Falkon profiles"
arch=('any')
url="https://github.com/bunnylo1/falkon-profiles"
license=("GPL3")
depends=("falkon" "libqt5core5a" "libqt5gui5" "libqt5widgets5")
provides=("tmulti")
makedepends=("git" "make" "gcc" "qtbase5-dev" "qt5-qmake")
source=(
"falkon::git+${url}" 
"falkonprofiles.desktop")
sha256sums=("SKIP" 
"db87ef452f6fd23df7d2f3836708535b5d48cd46353b4bca1cea29d8028cb46c")

prepare() {
    cd "$srcdir/falkon"
    qmake .
    make
}

package() {
    GITSRC="$srcdir/falkon"
    cd "${GITSRC}"
    INSTALL_ROOT=$srcdir make install
    install -Dm755 "${GITSRC}/falkon-profiles" -t "$pkgdir/usr/bin/"
    install -Dm644 "${srcdir}/falkonprofiles.desktop" -t "$pkgdir/usr/share/applications/"
}