makedeb
CLI for ente Photos
Viewing /PKGBUILD
.
Click here to go back to the Git tree for ente-cli-bin.
# Maintainer: Tai Lam <taivlam-aur-mpr [dot] tinsmith796 [at] silomails [dot] com>
# Contributor (from the AUR): twall <tomwallroth at gmail com>
pkgname="ente-cli-bin"
_pkgname="ente-cli"
pkgver=0.2.2
pkgrel=1
pkgdesc="CLI for ente Photos"
arch=('amd64' 'arm64')
url="https://github.com/ente-io/ente/tree/main/cli"
_url="https://github.com/ente-io/ente"
license=('AGPL-3.0-or-later')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=()
options=('!strip')
source_amd64=("${_url}/releases/download/cli-v${pkgver}/${_pkgname}-v${pkgver}-linux-amd64.tar.gz")
sha256sums_amd64=('034a070c7d71c51859d133efcaba3860c272be1392872d8c700fd8fadbcc4387')
source_arm64=("${_url}/releases/download/cli-v${pkgver}/${_pkgname}-v${pkgver}-linux-arm64.tar.gz")
sha256sums_arm64=('a3f0ab248e7eff2267ce9958a9ee889b4b2f39cff83a6c8663a7a104a1ee5e43')
build() {
tar xf "ente-cli-v${pkgver}-linux-${arch}.tar.gz"
}
package() {
install -Dm755 ente "${pkgdir}/usr/bin/ente"
}