makedeb


dunst 1.9.0-1


Lightweight and customizable notification daemon

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for dunst.

# Maintainer: only_vip <onlyme_vip@protonmail.com>
pkgname=dunst
pkgver=1.9.0
pkgrel=1
pkgdesc="Lightweight and customizable notification daemon"
arch=('amd64')
url="https://dunst-project.org/"
license=('BSD')
makedepends=('git' 'perl' 'wayland-protocols' 'libnotify-dev' 'libxss-dev' 'libxdg-basedir-dev' 'libghc-pango-dev' 'libxinerama-dev' 'libxrandr-dev' 'libwayland-client++0' 'libwayland-client-extra++0' 'libwayland-client0' 'libwayland-dev' 'libdbus-1-dev')
provides=('dunst' 'notification-daemon' 'dunstify')
conflicts=('dunst' 'dunstify')
# replaces=('dunst')
source=("https://github.com/dunst-project/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
sha512sums=("e43c960561d1f804c1d8f73f9376b33f61bf1ba5c5d0579c9875ef96da6522e214d5b74166ca3375dff1b4b0291b611b2d9ac1fb41fa8722db04c21e898824d1")
MAKEFLAGS="-j$(nproc)"

build() {
  cd "${pkgname}-${pkgver}"
  make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
  make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11 dunstify
}

package() {
  cd "${pkgname}-${pkgver}"
  make DESTDIR="${pkgdir}" PREFIX=/usr install
  install -Dm755 "dunstify" "${pkgdir}/usr/bin/dunstify"
  install -Dm755 "contrib/dunst_espeak.sh" "${pkgdir}/usr/bin/dunst_espeak.sh"
  install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}