makedeb


conmon 2.1.6-1


An OCI container runtime monitor.

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for conmon.

# Maintainer: hiddeninthesand <hiddeninthesand at pm dot me>

pkgname="conmon"
_gitname="conmon"
provides=('conmon')
pkgver='2.1.6'
pkgrel='1'
pkgdesc="An OCI container runtime monitor."
arch=("any")
url="https://github.com/containers/conmon"
license=('MIT')
makedepends=('golang-go' 'gcc' 'git' 'make' 'pkg-config')
depends=('runc' 'libc6-dev' 'libglib2.0-dev' 'libseccomp-dev')
sha256sums=('SKIP')
source=("git+https://github.com/containers/conmon.git#tag=v${pkgver}")
conflicts=("${_gitname}-git" "${_gitname}-bin")

build() {
	cd ${_gitname}
	make
}

package() {
    cd ${_gitname}
	make install PREFIX="${pkgdir}/usr"
}