makedeb


compix-git 114ac12c2022.01.23-4


an X compositor based on axcomp which is based on xcompmgr, improved to have animations

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for compix-git.

# Maintainer: only_vip <onlyme_vip@protonmail.com>
pkgname=compix-git
_pkgname=compix
pkgver=114ac12c2022.01.23
pkgrel=4
pkgdesc="an X compositor based on axcomp which is based on xcompmgr, improved to have animations"
arch=('amd64')
depends=('libconfuse2')
makedepends=( 'libxdg-basedir-dev' 'libconfuse-dev' 'libxdamage-dev' 'libxcomposite-dev' 'libxrender-dev')
optdepends=()
url="https://github.com/xeome/compix"
license=('custom:keith packard')
source=("${_pkgname}::git+${url}")
sha512sums=("SKIP")
provides=('compix')
conflicts=('compix')
#post_install=
MAKEFLAGS="-j$(nproc)"

pkgver() {
    cd "${srcdir}/${_pkgname}"
    _always=$(git describe --always | sed -e 's:-:.:g' -e 's:v::') # always is mobile, and switches between numbers and letters, can't use it for versioning
    _commits=$(git rev-list --count HEAD | sed 's:-:.:g') # total commits is the most sane way of getting incremental pkgver
    _date=$(git log -1 --date=short --pretty=format:%cd)
    printf "%s%s%s\n" "${_commits}" "${_always}" "${_date}" | sed -e 's:-:.:g'  -e 's:_:.:g'
}

package() {
    cd "${srcdir}/${_pkgname}"
    make all
    install -Dm755 "${srcdir}/${_pkgname}/out/compix" "${pkgdir}/usr/bin/compix"
    install -Dm644 "${srcdir}/${_pkgname}/compix.conf" "${pkgdir}/usr/share/doc/compix/compix.conf"
    install -Dm644 "${srcdir}/${_pkgname}/xinitrc" "${pkgdir}/usr/share/doc/compix/xinitrc"
    install -Dm644 "${srcdir}/${_pkgname}/readme.md" "${pkgdir}/usr/share/doc/compix/README"
    install -Dm755 "${srcdir}/${_pkgname}/run_xephyr.sh" "${pkgdir}/usr/share/doc/compix/run.xephyr.sh"
}