makedeb


chiaki 2.1.1-1


Free and Open Source PS4 Remote Play Client

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for chiaki.

# Maintainer: hiddeninthesand <hiddeninthesand at pm dot me>

pkgname='chiaki'
_gitname='chiaki'
provides=('chiaki')
pkgver='2.1.1'
pkgrel='1'
pkgdesc='Free and Open Source PS4 Remote Play Client'
arch=('x86_64')
license=('AGPL3')
url='https://git.sr.ht/~thestr4ng3r/chiaki'
makedepends=('git' 'build-essential' 'cmake')
depends=('python3-pip' 'qt5-default' 'qtmultimedia5-dev' 'libqt5svg5-dev' 'pyqt5-dev' 'ffmpeg' 'x264' 'libavcodec-dev' 'libopus-dev' 'openssl' 'protobuf-compiler' 'libssl-dev' 'libsdl2-dev' 'python3-protobuf')
source=("git+${url}#tag=v${pkgver}")
conflicts=("${_gitname}-git" "${_gitname}-bin")
sha256sums=('SKIP')

prepare() {
    cd "${srcdir}/${_gitname}"
    git submodule update --init --recursive
	# Switches the icons to SVG, why would you use PNG instead?
	sed -i "s/chiaki.png/res\/chiaki.svg/" "./gui/CMakeLists.txt"
	sed -i "s/512x512/scalable/" "./gui/CMakeLists.txt"
    cmake -S . -B build -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr
}

build() {
    cd "${srcdir}/${_gitname}/build"
    make
}

package() {
    cd "${srcdir}/${_gitname}/build"
    make install
}