makedeb


cargo-make 0.37.23-1


Rust task runner and build tool

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for cargo-make.

# Maintainer: Hunter Wittenborn <hunter@hunterwittenborn.com>
pkgname=cargo-make
pkgver=0.37.23
pkgrel=1
pkgdesc='Rust task runner and build tool'
arch=('any')
depends=('cargo')

source=("https://github.com/sagiegurari/cargo-make/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('SKIP')

build() {
    cd "${pkgname}-${pkgver}/"
    cargo build --release
}

package() {
    cd "${pkgname}-${pkgver}/"
    install -Dm755 -t "${pkgdir}/usr/bin/" target/release/{cargo-make,makers}
    install -Dm644 extra/shell/makers-completion.bash "${pkgdir}/usr/share/bash-completion/completions/makers"
}

# vim: set sw=4 expandtab: