makedeb


cargo-deb 2.9.0-2


Make Debian packages directly from Rust/Cargo projects

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for cargo-deb.

# Maintainer: Hunter Wittenborn <hunter@hunterwittenborn.com>
pkgname=cargo-deb
pkgver=2.9.0
pkgrel=2
pkgdesc='Make Debian packages directly from Rust/Cargo projects'
arch=('any')
depends=('cargo')

source=("https://github.com/kornelski/cargo-deb/archive/refs/tags/v${pkgver}.tar.gz")
sha256sums=('SKIP')

build() {
	cd "${pkgname}-${pkgver}/"
	cargo build --release
}

package() {
	cd "${pkgname}-${pkgver}/"
	install -Dm 755 "target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}

# vim: set sw=4 expandtab: