makedeb


caddy-bin 2.7.5-1


Fast web server with automatic HTTPS

Click here to go back to the commit logs for caddy-bin.

Commit:


Hash: 6f6997993355000ce795c089908d50bd54d3f4a2

Message: Change dependencies to match debian names. Go >= 1.16 required.

Diff


diff --git a/.SRCINFO b/.SRCINFO
index 6b75c50..f7bb606 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,9 +7,11 @@ pkgbase = caddy
 	url = https://caddyserver.com
 	arch = x86_64
 	license = Apache
-	makedepends = go
+	makedepends = gcc
+	makedepends = libc-dev
+	makedepends = golang-go>=2:1.16~1
 	makedepends = git
-	depends = glibc
+	depends = libc-bin
 	backup = etc/caddy/Caddyfile
 	source = git+https://github.com/caddyserver/caddy#tag=v2.4.5?signed
 	source = caddy-dist::git+https://github.com/caddyserver/dist#commit=093d76bdd6ecacd8aeb21de3aa0c35b82a0eb064
diff --git a/PKGBUILD b/PKGBUILD
index 81665cf..a1e72c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,8 +15,8 @@ pkgdesc='Fast web server with automatic HTTPS'
 url='https://caddyserver.com'
 arch=('x86_64')
 license=('Apache')
-depends=('glibc')
-makedepends=('go' 'git')
+depends=('libc-bin')
+makedepends=('gcc' 'libc-dev' 'golang-go>=2:1.16~1' 'git')
 backup=('etc/caddy/Caddyfile')
 source=("git+https://github.com/caddyserver/caddy#tag=${_gitcommit}?signed"
         caddy-dist::"git+https://github.com/caddyserver/dist#commit=${_distcommit}"