makedeb


btop 1.3.1-1


Resource monitor that shows usage and stats for processor, memory, disks, network and processes.

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for btop.

# Maintainer: Edgar <Edgar{at}AnotherFoxGuy.com>
# Contributor: Canony <canony@protonmail.ch>
# Contributor: Caleb Maclennan <caleb@alerque.com>

pkgname=btop
pkgver=1.3.1
pkgrel=1
pkgdesc='Resource monitor that shows usage and stats for processor, memory, disks, network and processes.'
arch=(amd64 aarch64)
url="https://github.com/aristocratos/$pkgname"
license=(Apache)
depends=(coreutils sed)
makedepends=(build-essential)
_archive="$pkgname-$pkgver"
source=("$_archive.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('9e7faa30550137598a712fc28c1fb907e48a1fa1a5b2fa2f939195cf91e1816e')

build() {
	cd "$_archive"
	make all
}

package() {
	cd "$_archive"
	make DESTDIR="$pkgdir" PREFIX=/usr install
}