makedeb
Web browser that blocks ads and trackers by default (binary release).
Viewing /PKGBUILD
.
Click here to go back to the Git tree for brave-bin.
# Please do not bother the arch aur maintainers.
# Mantainer: Kei Tachikawa <keitachikawa@protonmail.com>>
# https://aur.archlinux.org/packages/brave-bin/
pkgname=brave-bin
pkgver=1.26.77
pkgrel=1
epoch=1
pkgdesc="Web browser that blocks ads and trackers by default (binary release)."
arch=("x86_64")
url="https://brave.com/download"
license=("MPL2" "BSD" "custom:chromium")
depends=("gtk3" "nss" "alsa-lib" "libxss" "ttf-font")
optdepends=("cups: Printer support"
"libgnome-keyring: Enable GNOME keyring support"
"libnotify: Native notification support")
provides=("${pkgname%-bin}" "brave-browser")
conflicts=("${pkgname%-bin}")
source=("$pkgname-$pkgver.zip::https://github.com/brave/brave-browser/releases/download/v${pkgver}/brave-browser-${pkgver}-linux-amd64.zip"
"brave-browser.desktop"
"brave.png")
options=(!strip)
sha512sums=("ea70dd39df1b3b17d21b84177149f96a9226d69b3dbeecff5878c276f8feed831c761cb7650ee29bae4f729bccf5159ecf8b6484a9beccce3d72c52a5da10250"
"cbfe2edc06d5962a8a1f13707c91b03e21cd621ba4a8ad80b7c6143c8fd5302f17fae9e26a9e33c5eca250cf3b223a9219f6b70de12e0f4ff9cf0a0b1e2a05df"
"d7bef52e336bd908d24bf3a084a1fc480831d27a3c80af4c31872465b6a0ce39bdf298e620ae9865526c974465807559cc75610b835e60b4358f65a8a8ff159e")
noextract=("$pkgname-$pkgver.zip")
prepare() {
mkdir -p brave
bsdtar -xf $pkgname-$pkgver.zip -C brave
chmod +x brave/brave
}
_bsdtardir="brave"
package() {
install -d -m0755 "$pkgdir/usr/lib"
cp -a $_bsdtardir "$pkgdir/usr/lib/$pkgname"
# allow firejail users to get the suid sandbox working
chmod 4755 $pkgdir/usr/lib/brave-bin/chrome-sandbox
install -Dm0644 -t "$pkgdir/usr/share/applications" "brave-browser.desktop"
install -Dm0644 "logo.png" "$pkgdir/usr/share/pixmaps/brave-desktop.png"
LICENSES_DIR="$pkgdir/usr/share/licenses/$pkgname"
mkdir -p "$LICENSES_DIR"
if [ -f "$pkgdir/usr/lib/$pkgname/LICENSE" ] && [ -f "$pkgdir/usr/lib/$pkgname/LICENSES.chromium.html" ]; then
mv "$pkgdir/usr/lib/$pkgname/"{LICENSE,LICENSES.chromium.html} "$LICENSES_DIR"
fi
}