makedeb


bless 0.6.3-2


High-quality, full-featured hex editor (git version)

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for bless.

# Maintainer:zocker_160 <zocker1600 at posteo dot net>

pkgname=bless
pkgver=0.6.3
pkgrel=2
pkgdesc="High-quality, full-featured hex editor (git version)"
arch=('any')
url="https://github.com/afrantzis/bless"
license=('GPL2')
provides=('bless')
conflicts=('bless')
depends=('gtk-sharp2' 'mono-complete')
makedepends=('meson' 'git' 'ninja-build')
#source=("git+https://github.com/afrantzis/bless.git#tag=$pkgver")
source=("$pkgname-$pkgver.tar.gz::https://github.com/afrantzis/bless/archive/refs/tags/v$pkgver.tar.gz")
sha256sums=('547f2f28073fc791c9d52fa5fd7d66d92c42c7d7fecba05ce1e4b55278ff8cd4')


prepare() {
  cd ${srcdir}/$pkgname-$pkgver
  meson setup build -Dprefix=/usr -Dtests=false -Dhtml_user_doc=false --buildtype=release  
}

build() {
  cd ${srcdir}/$pkgname-$pkgver
  ninja -C build
}

package() {
  cd ${srcdir}/$pkgname-$pkgver
  DESTDIR="${pkgdir}" ninja -C build install
}