makedeb


bencodetools 1.0.1-0


A collection of tools for manipulating bencoded data.

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for bencodetools.

# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>
# Contributor: grimi (AUR)
pkgname=bencodetools
pkgver=1.0.1
pkgrel=0
pkgdesc="A collection of tools for manipulating bencoded data."
arch=("amd64")
url="https://gitlab.com/heikkiorsila/bencodetools"
license=("custom")
source=("https://gitlab.com/heikkiorsila/bencodetools/-/archive/v${pkgver}/bencodetools-v${pkgver}.tar.gz")
b2sums=('b260fe9cd9fd9c1ccdad7fe785b8b0d5cff689b16e14657c103717b729530c9b3d6ee5b12937fe7815a6a0bf495534ca23463712cebaaae53dc4ad15c9b83460')

build() {
  cd ${pkgname}-v${pkgver}
  ./configure --prefix=/usr  --lib-path=/usr/lib --package-prefix="${pkgdir}" --without-python
  make -j $(nproc)
}

package() {
  cd ${pkgname}-v${pkgver}
  make install
  install -Dm644 LICENSE "${pkgdir}"/usr/share/doc/${pkgname}/LICENSE
}