makedeb


bashtop-git r313.4bf71e6-1


Resource monitor that shows usage and stats for processor, memory, disks, network and processes.

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for bashtop-git.

# Maintainer: Tux <tux@hardwaretisch.de>
pkgname=bashtop-git
pkgver=r313.4bf71e6
pkgrel=1
pkgdesc="Resource monitor that shows usage and stats for processor, memory, disks, network and processes."
arch=('i386' 'x86_64')
url="https://github.com/aristocratos/bashtop"
license=('Apache')
depends=('bash')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('git+https://github.com/aristocratos/bashtop.git')
sha256sums=('SKIP')

pkgver() {
	cd "$srcdir/${pkgname%-git}"
	printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}

package() {
	cd "$srcdir/${pkgname%-git}"
	install -Dm755 "${pkgname%-git}" -t "$pkgdir/usr/bin"
	install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
}