makedeb


badown-git 0.4.r1.4baf0b8-1


Bash script to download files from mediafire, zippyshare and mega

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for badown-git.

# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>

_pkgname=badown
pkgname="${_pkgname}-git"
pkgver=0.4.r1.4baf0b8
pkgrel=1
pkgdesc="Bash script to download files from mediafire, zippyshare and mega"
arch=('all')
depends=('bash' 'wget' 'gzip' 'gawk' 'openssl' 'nodejs' 'coreutils' 'util-linux' 'xxd')
license=('GPL3')
url="https://github.com/stck-lzm/${_pkgname}"
provides=('badown')
conflicts=('badown')
source=("git+${url}.git")
b2sums=('SKIP')

pkgver() {
  cd "${srcdir}/${_pkgname}"
  printf "%s.r%s.%s" "$(grep -m 1 \"badown badown | cut -d '"' -f 2 | cut -d ' ' -f 2)" "$(git rev-list --count HEAD)" "$(git describe --long --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g')"
}

package() {
  cd "${srcdir}/${_pkgname}"
  # script
  install -Dm755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
  # docs
  install -Dm644 README.md "${pkgdir}/usr/share/doc/${_pkgname}/readme"
  _license_path="/usr/share/common-licenses/GPL-3"
  ln -s "${_license_path}" "${pkgdir}/usr/share/doc/${_pkgname}/"
}