makedeb


awesome-git 1c539e0e2022.03.21-2


Highly configurable framework window manager

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for awesome-git.

# Maintainer: only_vip <onlyme_vip@protonmail.com>
_pkgname=awesome
pkgname=${_pkgname}-git
pkgver=1c539e0e2022.03.21
pkgrel=2
pkgdesc='Highly configurable framework window manager'
arch=('i686' 'amd64')
url='http://awesome.naquadah.org/'
license=('GPL2')

depends=('libx11-6' 'libxcb-cursor0' 'libxcb-icccm4' 'libxcb-keysyms1' 'libxcb-randr0' 'libxcb-shape0' 'libxcb-util1' 'libxcb-xinerama0' 'libxcb-xkb1' 'libxcb-xrm0' 'libxcb-xtest0' 'libxcb1' 'libxdg-basedir1' 'libxkbcommon-x11-0' 'libxkbcommon0' 'libstartup-notification0' 'libglib2.0-0' 'libgdk-pixbuf2.0-0' 'libgdk-pixbuf-2.0-0' 'libdbus-1-3' 'libcairo2' 'libcairo-gobject2' 'gir1.2-glib-2.0' 'gir1.2-gdkpixbuf-2.0' 'gir1.2-freedesktop' 'lua5.3' 'liblua5.3-0' 'dbus-x11' 'libnotify-bin' 'wmctrl' 'x11-apps' 'xcb-proto' 'xdotool' 'xorg' 'lua-lgi')
makedepends=('asciidoctor' 'gir1.2-pango-1.0' 'gir1.2-gtk-3.0' 'git' 'gzip' 'lua-ldoc' 'imagemagick' 'asciidoc' 'xmlto' 'cmake' 'lua-busted' 'lua-check' 'liblua5.3-dev' 'libxcb-cursor-dev' 'libxcb-util0-dev' 'libxcb-keysyms1-dev' 'libxcb-icccm4-dev' 'libxcb-xkb-dev' 'libxkbcommon-dev' 'libstartup-notification0-dev' 'libxdg-basedir-dev' 'libxcb-xrm-dev' 'libxkbcommon-x11-dev' 'lua-lgi' 'libglib2.0-dev' 'libgdk-pixbuf2.0-dev' 'libxcb-xinerama0-dev' 'gettext' 'libdbus-1-dev' 'libgirepository1.0-dev' 'libpango1.0-dev' 'libx11-xcb-dev' 'libxcb-randr0-dev' 'libxcb-shape0-dev' 'libxcb-xfixes0-dev' 'xutils-dev' 'libluajit-5.1-dev' 'libcairo2-dev' 'lua-discount' 'x11proto-dev' 'libxcb-xtest0-dev' 'libmarkdown2' 'libyaml-dev' 'lua-any' 'lua-cliargs' 'lua-dkjson' 'lua-filesystem' 'lua-inifile' 'lua-luassert' 'lua-mediator' 'lua-penlight' 'lua-say' 'lua-system' 'lua-term' 'lua5.2' 'libc6'  'luajit' )
optdepends=('rlwrap: readline support for awesome-client'
            'dex: autostart your desktop files'
            'librsvg2-bin: for displaying SVG files without scaling artifacts'
            'xserver-xephyr: nested X server' 
            'xterm: X terminal emulator'
            'rxvt-unicode: RXVT-like terminal emulator with Unicode and 256-color support'
            'rxvt-unicode-256color: RXVT-like terminal emulator with Unicode and 256-color support'
            'zsh: shell with lots of features'
            'feh:   imlib2 based image viewer'
            'x11-xserver-utils:   X server utilities' 
            'awesome-extra:   additional modules for awesome'
            'gir1.2-gtk-3.0:  GTK graphical user interface library -- gir bindings'
            'menu: generates programs menu for all menu-aware applications' 
            'xvfb:  Virtual Framebuffer fake X server'
            'luarocks:  deployment and management system for Lua modules')
provides=('notification-daemon' 'awesome')
conflicts=('awesome')
backup=('/etc/xdg/awesome/rc.lua')
source=("${pkgname}::git+https://github.com/awesomeWM/awesome.git")
md5sums=('SKIP')
_LUA_VER=5.3
MAKEFLAGS="-j$(nproc)"
options=(!strip)

pkgver() {
  cd ${pkgname}
    _always=$(git describe --always | sed -e 's:-:.:g' -e 's:v::') # always is mobile, and switches between numbers and letters, can't use it for versioning
    _commits=$(git rev-list --count HEAD | sed 's:-:.:g') # total commits is the most sane way of getting incremental pkgver
    _date=$(git log -1 --date=short --pretty=format:%cd)
    printf "%s%s%s\n" "${_commits}" "${_always}" "${_date}" | sed -e 's:-:.:g'  -e 's:_:.:g'
}

build() {
  mkdir -p build
  cd build
  cmake ../$pkgname \
   -DCMAKE_BUILD_TYPE=RELEASE \
    -DCMAKE_INSTALL_PREFIX=/usr \
    -DSYSCONFDIR=/etc \
    -DLUA_INCLUDE_DIR=/usr/include/lua${_LUA_VER} \
    -DLUA_LIBRARY=/usr/lib/x86_64-linux-gnu/liblua${_LUA_VER}.so.0 \
    -DLUA_EXECUTABLE=/usr/bin/lua${_LUA_VER}
  make
}
package() {
  cd build
  make DESTDIR="$pkgdir" install
  install -Dm644 "$srcdir"/$pkgname/awesome.desktop \
    "$pkgdir/usr/share/xsessions/awesome.desktop"
}