makedeb


arch-wiki-docs 20230629-1


Page dump with no search, of the Arch Wiki for offline browsing

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for arch-wiki-docs.

# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>
# Contributor: George Rawlinson (ARCH) <grawlinson@archlinux.org>
# Contributor: Sergej Pupykin (ARCH) <pupykin.s+arch@gmail.com>
pkgname=arch-wiki-docs
pkgver=20230629
pkgrel=1
pkgdesc='Page dump with no search, of the Arch Wiki for offline browsing'
arch=('all')
url='https://github.com/lahwaacz/arch-wiki-docs'
license=('FDL')
makedepends=(
'python3' 'python3-simplemediawiki' 'python3-lxml' 'python3-cssselect' 'python3-requests'
)
options=('!strip')
# update commits from here
# https://gitlab.archlinux.org/archlinux/packaging/packages/arch-wiki-docs/-/raw/main/PKGBUILD
_commit='8082524dda618479fca65ab6cb13d69822d444bd'
source=("$pkgname-$_commit.zip::https://github.com/lahwaacz/arch-wiki-docs/archive/$_commit.zip")
b2sums=('d3fb2c2cd35e94ebd863bde3c63968f2af194ae39ea99b0fde9981be096cfa38855c019cc27fee19520bfeb3124beec8a983733cb1fda9937a73f5d910acf208')

pkgver() {
  date "+%Y%m%d"
}

prepare() {
  cd "$pkgname-$_commit"

  LANG=en_US.UTF-8 python3 \
    arch-wiki-docs.py \
    --output-directory "$srcdir/build_wiki" \
    --clean \
    --safe-filenames
}

package() {
  install -vdm755 "$pkgdir/usr/share/doc/arch-wiki/html"
  cp -r build_wiki/* "$pkgdir/usr/share/doc/arch-wiki/html"
}