makedeb


activate-linux 1.1.0-1


The "Activate Windows" watermark ported to Linux with Xlib and cairo in C

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for activate-linux.

# Maintainer: hiddeninthesand <hiddeninthesand at pm dot me>

pkgname="activate-linux"
_gitname="activate-linux"
pkgver='1.1.0'
pkgrel='1'
pkgdesc="The \"Activate Windows\" watermark ported to Linux with Xlib and cairo in C"
arch=("any")
url="https://github.com/MrGlockenspiel/activate-linux"
license=('GPL3')
makedepends=('build-essential')
depends=('libcairo2-dev' 'libxi-dev' 'libx11-dev' 'x11proto-core-dev' 'x11proto-dev' 'libxt-dev' 'libxfixes-dev' 'libxinerama-dev')
source=("git+https://github.com/MrGlockenspiel/activate-linux.git#tag=v${pkgver}"
        "activate-linux.desktop")
conflicts=("${_gitname}-git" "${_gitname}-bin")
b2sums=('SKIP'
        '3cb6d8680ac5cb72110b6a0deccf1afe812743f8c7ce62b09e0e39d219edfeedb3913169fc4ff44404c16d2776cf31f865bc7d4ba59684cfdda5304e6793f13a')

build() {
	cd "${srcdir}/${_gitname}"
    make
}

package() {
    install -D "activate-linux.desktop" "${pkgdir}/usr/share/applications/activate-linux.desktop"
    cd "${srcdir}/${_gitname}"
    install -Dm644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${_gitname}/LICENSE"
    install -D "./activate-linux" "${pkgdir}/usr/bin/activate-linux"
}