makedeb
Run your GitHub Actions locally
Viewing /PKGBUILD
.
Click here to go back to the Git tree for act.
# Maintainer: Hunter Wittenborn <hunter@hunterwittenborn.com>
pkgname=act
pkgver=0.2.42
pkgrel=1
pkgdesc='Run your GitHub Actions locally'
arch=('any')
depends=('docker.io')
makedepends=('golang-go')
url='https://github.com/nektos/act'
license=('MIT')
source=("${url}/archive/refs/tags/v${pkgver}.tar.gz")
sha256sums=('SKIP')
build() {
cd "${pkgname}-${pkgver}/"
go build -trimpath -buildmode=pie -ldflags "-linkmode=external -X main.version=$pkgver"
}
package() {
cd "${pkgname}-${pkgver}/"
install -Dm 755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}
# vim: set sw=4 expandtab: