makedeb
A session management and attach/detach functionality (to use together with dvtm(1)).
Viewing /PKGBUILD
.
Click here to go back to the Git tree for abduco-git.
# Maintainer: Alistair Bahr <alistair1231@gmail.com>
_pkgname=abduco
_owner='martanne'
pkgname=abduco-git
pkgver=8c32909
pkgrel=1
pkgdesc='A session management and attach/detach functionality (to use together with dvtm(1)).'
arch=('amd64')
url="https://github.com/$_owner/$_pkgname"
license=('ISC')
makedepends=('git')
provides=("$_pkgname=$pkgver-$pkgrel")
conflicts=('abduco')
source=("git+https://github.com/$_owner/$_pkgname")
md5sums=('SKIP')
pkgver() {
cd "$_pkgname"
git describe --long --always | sed 's/^v//; s/-/./g'
}
build() {
cd $_pkgname
./configure
make
}
package() {
cd "$_pkgname"
make PREFIX=/usr DESTDIR="$pkgdir" install
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 README.md $pkgdir/usr/share/doc/${pkgname%-*}/README.md
}