makedeb


libcegui-0.7.9 0.7.9-1


Old version of libcegui for compiling old applications

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for libcegui-0.7.9.

# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>
# Contributor: AUR

pkgname=libcegui-0.7.9
pkgver=0.7.9
pkgrel=1
pkgdesc="Old version of libcegui for compiling old applications"
arch=('i386' 'amd64')
url="http://crayzedsgui.sourceforge.net"
license=("MIT")
depends=('libpcre3' 'libexpat1' 'libfreetype6' 'libxml2' 'libdevil1c2' 'libglut3.12' 'liblua5.1-0' 'libsilly')
makedepends=('libpcre3-dev' 'libexpat1-dev' 'libfreetype6-dev' 'libxml2-dev' 'libdevil-dev' 'libglut-dev' 'liblua5.1-0-dev' 'libsilly-dev' 'autoconf')
bullseye_depends=('libpcre3' 'libexpat1' 'libfreetype6' 'libxml2' 'libdevil1c2' 'freeglut3' 'liblua5.1-0' 'libsilly')
bullseye_makedepends=('libpcre3-dev' 'libexpat1-dev' 'libfreetype6-dev' 'libxml2-dev' 'libdevil-dev' 'freeglut3-dev' 'liblua5.1-0-dev' 'libsilly-dev' 'autoconf')
source=("http://downloads.sourceforge.net/crayzedsgui/CEGUI-$pkgver.tar.gz")
b2sums=('b4c827e489ecf8a963715845c32ecd6e792e7ada6af5f69373a7f774ef51719b220da7d0dee8a0746ee06dde4d5796bd003b1fe27d2ba061b5f418461801ca67')

build() {
  cd $srcdir/CEGUI-$pkgver

  # fix compilation
  export CXXFLAGS="${CXXFLAGS} -fpermissive"

  ./configure --prefix=/usr --sysconfdir=/etc --enable-devil --enable-silly \
      --disable-xerces-c --with-default-image-codec=SILLYImageCodec \
      --enable-lua --disable-samples
  make -j $(nproc)
}

package(){
  cd $srcdir/CEGUI-$pkgver
  make DESTDIR="$pkgdir/" install
  install -D -m644 doc/COPYING $pkgdir/usr/share/doc/$pkgname/COPYING
}