makedeb
Download files from https://gofile.io
Viewing /PKGBUILD
.
Click here to go back to the Git tree for gofile-downloader-git.
# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>
# Contributor: katt (AUR) <magunasu.b97@gmail.com>
pkgname=gofile-downloader-git
pkgver=0.r1.44bf74f
pkgrel=1
pkgdesc='Download files from https://gofile.io'
arch=(all)
url="https://github.com/ltsdw/${pkgname%-git}"
license=(GPL3)
depends=('python3' 'python3-certifi' 'python3-charset-normalizer' 'python3-idna' 'python3-requests' 'python3-urllib3')
makedepends=(git)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=(git+"${url}".git)
b2sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
cd "${srcdir}/${pkgname%-git}"
# script
install -Dm755 "${pkgname%-git}.py" "${pkgdir}/usr/bin/${pkgname%-git}"
# docs
install -Dm644 README.md "${pkgdir}/usr/share/doc/${_pkgname}/readme"
_license_path="/usr/share/common-licenses/GPL-3"
ln -s "${_license_path}" "${pkgdir}/usr/share/doc/${_pkgname}/"
}