makedeb
gh, official github cli repo
Viewing /PKGBUILD
.
Click here to go back to the Git tree for gh-repo.
# Maintainer: exponential <echo ZXhwb25lbnRpYWxtYXRyaXhAcHJvdG9ubWFpbC5jb20K | base64 -d>
pkgname=gh-repo
pkgver=0
pkgrel=0
pkgdesc='gh, official github cli repo'
arch=('all')
license=('MIT')
source=('https://cli.github.com/packages/githubcli-archive-keyring.gpg')
b2sums=('c01ee63481694b5bae0c6e470d9497abbd2e1df365b6a89a62d52d37d3824d07877c9941689c1291da3096cbf7e2486def6622eff5b9cb5ff8bd55ed3dc3b92c')
package() {
cd $srcdir
# install source file
install -dm755 "${pkgdir}/etc/apt/sources.list.d"
echo "deb [arch=$(dpkg --print-architecture) signed-by=/usr/share/keyrings/githubcli-archive-keyring.gpg] https://cli.github.com/packages stable main" > "${pkgdir}/etc/apt/sources.list.d/github-cli.list"
# intall key
install -Dm644 "githubcli-archive-keyring.gpg" "${pkgdir}/usr/share/keyrings/githubcli-archive-keyring.gpg"
}