makedeb
GitHub’s official command line tool.
Viewing /PKGBUILD
.
Click here to go back to the Git tree for gh-bin.
# Maintainer: hiddeninthesand <hiddeninthesand at pm dot me>
pkgname="gh-bin"
provides=('gh')
pkgver='2.20.2'
pkgrel='1'
pkgdesc="GitHub’s official command line tool."
arch=('x86_64')
depends=('git')
license=('MIT')
url="https://github.com/cli/cli"
conflicts=("gh-git" "gh")
source=("${url}/releases/download/v${pkgver}/gh_${pkgver}_linux_amd64.deb")
b2sums=('e0569ae5ec3df2d3be67e9d055b5ac818f113ecf0022c4eb8155734f98d81472effbcef9790e504dbc55bfa16dc5af3d9df7dd4a7febeb598aa9cdaa36de6da3')
package() {
# Extract data.tar.xz to pkgdir
msg2 "Extracting data.tar.gz..."
tar -xf 'data.tar.gz' -C "${pkgdir}"
}