makedeb


getoptions 3.3.0-1


An elegant option/argument parser for shell scripts

Viewing /PKGBUILD.

View raw.

Click here to go back to the Git tree for getoptions.

# Maintainer: yaroslav2424 <julia.schweinz@mailfence.com>
# Contributor: Yamada Hayao <development@fascode.net>

_pkgname="getoptions"
pkgname="${_pkgname}"
pkgdesc="An elegant option/argument parser for shell scripts"
pkgver="3.3.0"
pkgrel="1"

arch=('any')
url="https://github.com/ko1nksm/getoptions"
license=('CC0-1.0')
conflicts=("${_pkgname}-git")

source=("${url}/archive/refs/tags/v${pkgver}.zip")
md5sums=('5b24f969d7e55fe3f7fef27dd55c7453')

_dir="getoptions-${pkgver}"

build(){
    cd "${srcdir}/${_dir}"
    make
}

package() {
    cd "${srcdir}/${_dir}"
    make install PREFIX="${pkgdir}/usr/"
}